#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:(?!.*LT circa).+\n)*(?:(?!LT circa).)*LT circa\s+(\d\d\.\d\d.\d{4})(?!(?:.+\n)*.*LT circa)"
Local $sString = "Metall-Notierung 464,95 EUR 100 KG" & @CRLF & _
"* LT circa 21.04.2020 2 x 500 M Einwegtrommel 400x 150x 404mm" & @CRLF & _
"* LT circa 17.05.2020 2 x 500 M Einwegtrommel 400x 150x 404mm" & @CRLF & _
"Zolltarifnummer 80464995"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")