import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!.*LT circa).+\\n)*(?:(?!LT circa).)*LT circa\\s+(\\d\\d\\.\\d\\d.\\d{4})(?!(?:.+\\n)*.*LT circa)";
final String string = "Metall-Notierung 464,95 EUR 100 KG\n"
+ "* LT circa 21.04.2020 2 x 500 M Einwegtrommel 400x 150x 404mm\n"
+ "* LT circa 17.05.2020 2 x 500 M Einwegtrommel 400x 150x 404mm\n"
+ "Zolltarifnummer 80464995";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}