$re = '/^(?:(?!.*LT circa).+\n)*(?:(?!LT circa).)*LT circa\s+(\d\d\.\d\d.\d{4})(?!(?:.+\n)*.*LT circa)/';
$str = 'Metall-Notierung 464,95 EUR 100 KG
* LT circa 21.04.2020 2 x 500 M Einwegtrommel 400x 150x 404mm
* LT circa 17.05.2020 2 x 500 M Einwegtrommel 400x 150x 404mm
Zolltarifnummer 80464995';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);