using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^www[0-9]*\.((?:[^.\n]*\.)+)";
string substitution = @"$1";
string input = @"www.by
www.ru
www.example.org
www.sub.example.org
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}