#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9]+[a-zA-Z]?(\/[0-9]+[a-zA-Z])?"
Local $sString = "1111111c/1111111" & @CRLF & _
"11a/111b" & @CRLF & _
"11/11a" & @CRLF & _
"11/112" & @CRLF & _
"111121112" & @CRLF & _
"" & @CRLF & _
"1111111C/" & @CRLF & _
"1111111c/" & @CRLF & _
"/1111111c" & @CRLF & _
"ccccccc/11111" & @CRLF & _
"1111/cccc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")