re = /[0-9]+[a-zA-Z]?(\/[0-9]+[a-zA-Z])?/
str = '1111111c/1111111
11a/111b
11/11a
11/112
111121112
1111111C/
1111111c/
/1111111c
ccccccc/11111
1111/cccc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end