$re = '/\b(?=[A-Z]{3}\b)A?([B-Z])A?\1A?\b/m';
$str = 'BBA -> true
ABB -> true
BAB -> true
CCA -> true
AAA -> false (change "[B-Z]" to "[A-Z]" to match this)
CCB -> false
ABC -> false
BAC -> false
BBBA -> false (there have to be only two)
ABBB -> false (there have to be only two)
ABBA -> false (there has to be only one A)
BABA -> false (there has to be only one A)
BBAA -> false (there has to be only one A)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);