package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[a-zA-Z]+@[a-zA-Z]+:(?:[a-z]+[\/])*([-a-z]+)::[a-zA-Z]+[0-9]+>`)
var str = `<ProjectName@component:path/to/component-name::ember793>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}