#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^The (\S+) ball is \1\.$"
Local $sString = "The red ball is red." & @CRLF & _
"The soft ball is soft." & @CRLF & _
"The batman ball is batman." & @CRLF & _
"The batman ball is batmane." & @CRLF & _
"The batman balls is batman."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")