using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^The (\S+) ball is \1\.$";
string input = @"The red ball is red.
The soft ball is soft.
The batman ball is batman.
The batman ball is batmane.
The batman balls is batman.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}