re = /^The (\S+) ball is \1\.$/m
str = 'The red ball is red.
The soft ball is soft.
The batman ball is batman.
The batman ball is batmane.
The batman balls is batman.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end