#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=[<>@[\\^{~])(?<=(?<!\\)|(?<!\\)(?:\\{2}))(?:\[(?:(?:\/?(?:[\*'bcimpstu]|com|ex|lang|ref|trn1?|!trs|su[bp]|url))|(?:m\d|c\x20[a-z]{3,20}|lang\x20(?:id=\d{1,5}|name="[A-Za-z]{5,22}")|ref(?:\x20dict="[^\r\n"]+")|br))\]|[\\@~^]|{{2}[\s\S]*?}{2}|<{2}|>{2})"
Local $sString = "{{ Техническая часть }}" & @CRLF & _
"" & @CRLF & _
"{{ / Техническая часть }}" & @CRLF & _
"" & @CRLF & _
" [m0][c olive][b][com]New Heading, [p]сокр.[/p] NH[/com][/b][/c] {{ Полная и сокращенная форма заголовка }}" & @CRLF & _
" [m0][t]\[əˈθʌˌʤʊ ˈæʧɔːʃɪŋ\][/t] [s]sound.wav[/s] {{ Транскрипция и аудиоклип произношения }}" & @CRLF & _
" [m0][c darkviolet]I[/c] {{ Первая римская цифра }}" & @CRLF & _
" [m0][p]комп.[/p] [p]прог.[/p] [p]сущ.[/p] {{ Зона помет }}" & @CRLF & _
" [m1][c indigo]перев[']о[/']д т[']е[/']рмина п[']е[/']рвый[/c] {{ Перевод }}" & @CRLF & _
" [m0][c darkviolet]II[/c] {{ Вторая римская цифра }}" & @CRLF & _
" [m0] [p]техн.[/p] [p]гл.[/p] {{ Зона помет }}" & @CRLF & _
" [m1][c maroon][b]1.[/b][/c] [c indigo]п[']е[/']рвый перев[']о[/']д т[']е[/']рмина[/c] {{ Перевод }}" & @CRLF & _
" [m1][c maroon][b]2.[/b][/c] [c indigo]втор[']о[/']й перев[']о[/']д т[']е[/']рмина[/c] {{ Перевод }}" & @CRLF & _
" [*] • • •[/*] {{ Разгрничитель }}" & @CRLF & _
" [m1][*][s]press_brake.gif[/s][/*]" & @CRLF & _
" [m1][*][p]Аним.[/p] Схема работы. [i][c silver]Изображение: wiki.[/c][/i][/*]" & @CRLF & _
" [*] [/*]" & @CRLF & _
" [m1] Продолженние любого действия в проявленнном мире происходит в непроявленном мире. Начало любого материального действия происходит в уме, а ещё ранее — в психической сфере (то есть, в непроявленном мире). Графической схемой растения [ref dict="Mostitsky Universal (Ru-Ru)"]малина[/ref] является дерево корнями вверх, кроной вниз.[/com] {{ Комментарий }}" & @CRLF & _
" [m2][*][ex]♦ Пример абстрактного предложения на тему словарной статьи. [c lightblue](Иван Петров)[/c][/ex][/*] {{ Пример }}" & @CRLF & _
" {{[!trs]}}[*] • • •[/*]{{[/!trs]}} {{ Разграничитель }}" & @CRLF & _
" [m0][*][com][p]син.[/p] <<Карточка с заголовком X>>, empty article, sample (test) card[/com][/*] {{ Зона синонимов и антонимов }}" & @CRLF & _
" [m0][*][com][p]букв.[/p] буквальный перевод; [p]этим.[/p] dummy («болванка») + entry («запись»); [p]появл.[/p] 1999[/com][/*] {{ Этимология }}" & @CRLF & _
" [m0][*]► [i][com]Wiki (Eng):[/com][/i] [url]http://en.wikipedia.org[/url][/*] {{ Внешние ссылки - на сайты }}" & @CRLF & _
" [m0][*]► [i][com]Wiki (Eng):[/com][/i] [url]{{http://}}www.en.wikipedia.org[/url][/*]" & @CRLF & _
" [m0][*]► [i][com]Сайт (Rus):[/com][/i] [url]www.goo.gl/XLFQnc[/url][/*]" & @CRLF & _
" [m0][*][p]см.[/p] <<О словаре>>[/*] {{ Внутренние ссылки. Вариант 1 }}" & @CRLF & _
" [m0][*][p]см. тж[/p] {{ Внутренние ссылки. Вариант 2 }}" & @CRLF & _
" - <<команды DSL>>" & @CRLF & _
" - [ref]вложенная карточка[/ref]" & @CRLF & _
" - <<особые статьи словаря>>" & @CRLF & _
" - <<контрольная карточка>>" & @CRLF & _
" [/*]" & @CRLF & _
" [*] [/*] {{ Картинка или фото. Вариант 1 }}" & @CRLF & _
" [m1][*][s]Photo.jpg[/s][/*]" & @CRLF & _
" [m1][*][com][p]Рис.[/p] Подпись к рисунку [i]с выделением[/i]. [i][c silver]Изображение: Имя Автора.[/c][/i][/com][/*]" & @CRLF & _
" [*] [/*] {{ Картинка или фото. Вариант 1 }}" & @CRLF & _
" [m1][*][s]MP4_video.avi[/s][/*]" & @CRLF & _
" [m1][*][com][p]Видео:[/p] Подпись к видеоклипу [i]MP4[/i]. [i][c silver]Автор: Имя Фамилия.[/c][/i][/com][/*]" & @CRLF & _
" [m1][p]▪[/p] [com][c gainsboro]05.04.2015[/c][/com] {{ Дата обработки карточки }}" & @CRLF & _
" {{ ≡05.04.2015 }} {{ Зона служебных комментариев }}" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")