using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"The previous system shutdown at [\w\s\-:\?\d\/]* was unexpected. for \S*";
string input = @"This is text with something in the middle of it like The previous system shutdown at 12:24:41 AM on ?2/?2/?2025 was unexpected. for MDO-SQL and we will ignore all the stuff before and I after it. ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}