package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`The previous system shutdown at [\w\s\-:\?\d\/]* was unexpected. for \S*`)
var str = `This is text with something in the middle of it like The previous system shutdown at 12:24:41 AM on ?2/?2/?2025 was unexpected. for MDO-SQL and we will ignore all the stuff before and I after it. `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}