$re = '/[^=;]+(?<!TEST.)=[^;]+(?:$|;)/m';
$str = 'TESTA=abc; VAL2=def; TESTB=ghi; TESTC=jkl; VAL2=bla1; VAL3=bla2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);