const regex = /get_option\((.[^)]*)\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('get_option\\((.[^)]*)\\)', '')
const str = `if(get_option(\$id,'')==\$o){\$selected='selected';}
stripslashes(get_option(aaa))
get_option(bbb)
get_option(ccc)
get_option(ddd)
get_option(eee)
get_option(fff)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}