import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\".+?id=(.+?)\"";
final String string = "<a href=\"#SCRIPT_NAME#?a=b&id=a/b/c/d\">Link Content</a>";
final String subst = "href=\"/lookup?id=$1\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}