re = /('.*?'|".*?"|\S+)/m
str = 'Class \'Occultist\'ssss Vestment "Occultist\'s Vestment" "Occultist\'s" Vestment'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end