$re = '/^[0-9A-Za-z]*[!@#$%^&*()_+\-=\[\]{};\':"\\\\|,.<>\/?][0-9a-zA-Z]*$/mi';
$str = '@
@a
a@
aa
aa@@
THisisSome#randomPassword';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);