$re = '/\(?(((((([hH]?[tT]?)|[fF]?)[tT]?[pP]?s?:?)?(\/\/)?|[A-Za-z]+|(\/\/)?)?[A-Za-z]+)\.\S+(\/|\.|#)\S+)(?!(\.com))\)?/m';
$str = 'DONT MATCH $200.00/month... for positioningacceleratorprogram.com
on youtube.com eeeee https://www. //www. or not def//: :google.com ://google.com google.com or ld/2018/01/02/mountains-u-s-recycling-pile-up-china-restricts-imports/995134001/
atis:theexpertiseincubator.simplecast.fm/ This
MATCH
www.google.com
https://wWw.csis.org
http://youtu.be/abS#PS9
hotshot.io#hash
htTps://buFf.ly/2as34vz/MN
https://www.usatoday.com/story/news/wor
www.asas.io
doggie.io/x doggie.io#taggie usatoday.com/story/news/world/2018/01/02/mountains-u-s-recycling-pile-up-china-restricts-imports/995134001/
https://www.google.com
http://www.google.com
www.google.com
htt://www.google.com
://www.google.com
here: forms.gle/7j6rFkUjbKXr2skC6 A few again: forms.gle/7j6rFkUjbKXr2skC6 -P (yet): www.acrecoffee.com/shop coffee (nmpinoncoffee.com/products/Traditional%20Piñon?category=coffee0) and (Readin\' time: 33 seconds) This is interesting: www.cnbc.com/2019/04/26/the-15-us-jobs-disappearing-the-fastest.html Not of this htfps:theexpertiseincubator.simplecast.fm/ This
httPs:theexpertiseincubator.simplecast.fm/ This
Life: https://www.thisamericanlife.org/7/quitting Frequency, audience: offlinepodcast.rocks/paid-acquisitions (the setup) offlinepodcast.rocks/podcast-listeners (the payoff).
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);