using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!<scr>).)*<scr>(?!.*<scr>).*$";
string input = @"hello-<scr>Keephello-endofstring
hello-<scr><scr>Keephello-endofstring
//NOT OK
test-<scr>bla<scr>bla-end
hello-Keephello-end ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}