import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http://(www\\.)?(schema\\.org|stackoverflow\\.com|opensource\\.org|php\\.net|(?:[a-zA-Z]{2}\\.)?wikipedia\\.org|fsf\\.org|creativecommons\\.org|github\\.com|getbootstrap\\.com|mozilla\\.org|firefox\\.com|opera\\.com|google\\.com|bing\\.com|yahoo\\.com|apple\\.com|microsoft\\.com)";
final String string = "http://schema.org/\n"
+ "http://getbootstrap.com/\n"
+ "http://github.com/\n\n"
+ "http://wikipedia.org\n"
+ "http://www.wikipedia.org\n"
+ "http://en.wikipedia.org";
final String subst = "https://\\1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}