import Foundation
let pattern = #"http://(www\.)?(schema\.org|stackoverflow\.com|opensource\.org|php\.net|(?:[a-zA-Z]{2}\.)?wikipedia\.org|fsf\.org|creativecommons\.org|github\.com|getbootstrap\.com|mozilla\.org|firefox\.com|opera\.com|google\.com|bing\.com|yahoo\.com|apple\.com|microsoft\.com)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
http://schema.org/
http://getbootstrap.com/
http://github.com/
http://wikipedia.org
http://www.wikipedia.org
http://en.wikipedia.org
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)