using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" +(?=[A-Z\d])";
string input = @"1.6.1 Members................................................................ 12
1.6.2 Accessibility.......................................................... 13
1.6.3 Type parameters........................................................ 13";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}