# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\d+)\b/CInt(\1)/g;t' <<< "Dim A As Integer = 1337
Dim B As Integer = (5 / 2)
Dim C$ = Base64Int(A)"