$re = '/\b(\d+)\b/';
$str = 'Dim A As Integer = 1337
Dim B As Integer = (5 / 2)
Dim C$ = Base64Int(A)';
$subst = "CInt(\1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;