// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(\d+)\b").unwrap();
let string = "Dim A As Integer = 1337
Dim B As Integer = (5 / 2)
Dim C$ = Base64Int(A)";
let substitution = "CInt(\\1)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}