import Foundation
let pattern = #"^([[:alpha:]]+:\/\/.+?[?&]mod=)(.+?)(:.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Example: LINK: http://l.corp.help.com/help/me.php?mod=jp_james:thank you
http://l.corp.help.com/help/me.php?mod=jp_james:thank you
http://l.corp.help.com/help/me.php?type=testmod=jp_james:thank you
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}