$re = '/(^[\p{L} -]+$)/um';
$str = 'my string is nice 123 and it is cool
regular string
this is fine too
this however, is not';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);