$re = '/^[a-z][a-z0-9]*(?:([-_])[a-z0-9]+(?:\1[a-z0-9]+)*)?$/m';
$str = 'foo
foo-bar
foo_bar
foo-bar-baz
foo_bar_baz
= passed (but I don\'t want it to)
foo-bar_baz_qux
foo_bar-baz-quz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);