#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)/@[^/@]*(*SKIP)(*F)|[^/]+"
Local $sString = "path/to/folder/@here"
Local $sSubst = "a:$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)