$re = '`/@[^/@]*(*SKIP)(*F)|[^/]+`m';
$str = 'path/to/folder/@here';
$subst = "a:$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;