#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d)|(\*.*)"
Local $sString = "hello23 the2e are 13 5.12apples *specially_x00123 named"
Local $sSubst = "#\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)