using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)|(\*.*)";
string substitution = @"#\2";
string input = @"hello23 the2e are 13 5.12apples *specially_x00123 named";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}