use strict;
my $str = 'hello23 the2e are 13 5.12apples *specially_x00123 named';
my $regex = qr/(\d)|(\*.*)/mp;
my $subst = '#\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";