// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d)|(\*.*)").unwrap();
let string = "hello23 the2e are 13 5.12apples *specially_x00123 named";
let substitution = "#\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}