const regex = /^Specs:(?:(?!^Specs:)[\s\S])*UnknownError:\s*(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Specs:(?:(?!^Specs:)[\\s\\S])*UnknownError:\\s*(.*)', 'gm')
const str = `Specs: /var/lib/jenkins-slave/workspace//tests/js/e2e/ui_e2e/tests/test_one.js
Selenium URL: http://10.20.40.54:4444/wd/hub
..... number of different strings here....
Executed 25 of 25 specs SUCCESS in 1 min 23 secs.
-----
Specs: /var/lib/jenkins-slave/workspace//tests/js/e2e/ui_e2e/tests/test_two.js
..... number of different strings here....
UnknownError: Due to a previous error, this job has already finished. You can learn more at`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}