re = /endpointKeyHash\":\{\"string\":\"(?<endpointKeyHash>[^\=\"]*)/
str = '2641328 [EPS-log-dispatcher-11] INFO 1.24978294676695149906 - {"Log Header": "{"endpointKeyHash":{"string":"MAz7MadOhr02tPt5vtZsSEy9FWw="},"applicationToken":{"string":"24978294676695149906"},"headerVersion":{"int":1},"timestamp":{"long":1495594584490},"logSchemaVersion":{"int":2}}","Event":{"temperature":-1,"timeStamp":1495594583638}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end