import Foundation
let pattern = #"^[a-fA-F0-9]{24}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"617c4d302bdaae79da0a6778"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}