re = /\brecord {[^{}]*my_id_[123][^{}]*}/m
str = 'record {
record {
id my_id_1
my_name_1
}
record {
id my_id_2
my_name_2
}
record {
id my_id_3
my_name_3
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end