use strict;
my $str = '0
0.
0.0
0.00
0.0e0
0.0e-0
0.0e+0
+0
+0.
+0.0
+0.00
+0.0e0
+0.0e-0
+0.0e+0
-0
-0.
-0.0
-0.00
-0.0e0
-0.0e-0
-0.0e+0
1.
2.
3.
4.
-1.
-2.
-3.
-4.
.1
.2
.3
.4
-.1
-.2
-.3
-.4
1.0
3.0
4.0
5.0
-1.0
-2.0
-3.0
-4.0
-5.0
5.0123456
-5.012345678
-1
10
-10
10.0
-10.0
-10.01234
10.01234
0
1
01
001
1
Ne doit pas être validé
.
1..
.1.
..1
toto
1a
a1
a1a
1 a
a 1
a 1 a
-.1.
+.1.';
my $regex = qr/(^[\s]*[-+]?[0-9]*?\.?[0-9]+([eE][-+]?[0-9]+)?[\s]*$|^[\s]*[-+]?[0-9]+\.?[\s]*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}