# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^[\s]*[-+]?[0-9]*?\.?[0-9]+([eE][-+]?[0-9]+)?[\s]*$|^[\s]*[-+]?[0-9]+\.?[\s]*$)"
test_str = ("0\n"
"0.\n"
"0.0\n"
"0.00\n"
"0.0e0\n"
"0.0e-0\n"
"0.0e+0 \n"
"+0 \n"
"+0. \n"
"+0.0\n"
"+0.00\n"
"+0.0e0\n"
"+0.0e-0\n"
"+0.0e+0\n"
"-0 \n"
"-0.\n"
"-0.0\n"
"-0.00\n"
"-0.0e0\n"
"-0.0e-0\n"
"-0.0e+0\n"
"1.\n"
"2.\n"
"3.\n"
"4.\n"
"-1.\n"
"-2.\n"
"-3.\n"
"-4.\n"
".1\n"
".2\n"
".3\n"
".4\n"
"-.1\n"
"-.2\n"
"-.3\n"
"-.4\n"
"1.0\n"
"3.0\n"
"4.0\n"
"5.0\n"
"-1.0\n"
"-2.0\n"
"-3.0\n"
"-4.0\n"
"-5.0\n"
"5.0123456\n"
"-5.012345678\n"
"-1\n"
"10\n"
"-10\n"
"10.0\n"
"-10.0\n"
"-10.01234\n"
"10.01234\n"
"0\n"
"1\n"
"01\n"
"001\n"
" 1 \n\n"
"Ne doit pas être validé\n\n"
".\n"
"1..\n"
".1.\n"
"..1\n"
"toto\n"
"1a\n"
"a1\n"
"a1a\n"
"1 a\n"
"a 1\n"
"a 1 a\n"
"-.1.\n"
"+.1.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.