$re = '/(\/\*<<@\*\/)((?:[^\/]|\/(?!\*))+?)(\/\*)((?:[^*]|\*(?!\/))+?)(\*\/)/m';
$str = '/*<<@*/ \'2018-07-20 00:00:00\' /*My Date>>*/
/*<<@*/ \'whatever?\' /*My String>>*/
/*<<@*/ 1 /*My Bool>>*/
/*<<@*/whate/er*/a*/*aoe*u*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);