$re = '/https?:\/\/\S+/';
$str = 'Lorem ipsum dolor sit amet, consetetur sadipscing http://www.loremipsum.com/asd/fgh/jkl elitr, sed diam ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);