const regex = /User-Agent: (?<UserAgent>[^\\r\\n]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('User-Agent: (?<UserAgent>[^\\\\r\\\\n]*)', 'gm')
const str = `POST /xxx/yyyy HTTP/1.1\\r\\nUser-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0\\r\\nAccept: application/json\\r\\nAccept-Language: en-US,en;q=0.5\\r\\nX-XSRF-TOKEN: 989g8ddfgdf7979df\\r\\ntimestamp: 2021-04-07T18:35:50.639Z\\r\\nContent-Type: application/json;charset=utf-8\\r\\nContent-Length: 340\\r\\nOrigin: https://example.com\\r\\nConnection: keep-alive\\r\\nReferer: https://my.example.com\\r\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}