// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)User-Agent: (?<UserAgent>[^\\r\\n]*)").unwrap();
let string = "POST /xxx/yyyy HTTP/1.1\\r\\nUser-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0\\r\\nAccept: application/json\\r\\nAccept-Language: en-US,en;q=0.5\\r\\nX-XSRF-TOKEN: 989g8ddfgdf7979df\\r\\ntimestamp: 2021-04-07T18:35:50.639Z\\r\\nContent-Type: application/json;charset=utf-8\\r\\nContent-Length: 340\\r\\nOrigin: https://example.com\\r\\nConnection: keep-alive\\r\\nReferer: https://my.example.com\\r\\n";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}