import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<group>(?<value>[^()\\r\\n]+)*\\((?<groupVal>(?&group)|(?&value))\\)(?&groupVal)*)$";
final String string = "(F(i(r(s)t))) ((S)(e)((c)(o))n)d) (((((((Third)))))))\n"
+ "(F(i(r(s)t))) ((S)(e)((c)(o))n)d (((((((Third)))))))\n"
+ "((F(i(r(s)t))) ((S)(e)((c)(o))n)d) (((((((Third)))))))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}