const regex = /(STRING.*?)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(STRING.*?)\\)', 'gm')
const str = `foo)bar)baz STRING foo)bar`;
const subst = `$1]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);