package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w-]+([\w.]*[\w-]+)?$`)
var str = `-abc-
_abc_
_abc.xyz_
a
_
-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}