$re = '/(#(?<tag>[A-Za-zА-Яа-я]{1,19})\s*)+/m';
$str = '#asdf #fdsa #фываолрф';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);